Select Your Language

免責事項

  • 本サイトの情報の利用、内容、サービスによって、利用者にいかなる損害、被害が生じても、著者は一切の責任を負いません。ユーザーご自身の責任においてご利用いただきますようお願いいたします。

    本サイトで頒布している基板およびキットは、技術者、またはそれに準ずる電気的知識をお持ちの電子工作ファンの方のためのものです。 一般のオーディオファンの方のためのものではありません。
    また、頒布基板およびキットは、いかなる条件でも動作を保証するものではございませんので、あらかじめご了承ください。

    電子工作では、火傷、感電、火災などの可能性があります。 十分に注意をして作業して下さい。

    営利目的のご使用は認めておりません。  記事の転載や、基板・キットの商用利用の方は、ご連絡ください。
    学生やサークルの学習目的でまとめてご購入する場合は特別なコースをご用意させていただきます。

« Raspberry Pi / volumio のCPU負荷を計測 | トップページ | 対決は突然に VoyageMPD VS Volumio Pi »

2014年1月23日 (木)

volumioのトラブルシューティング?

先月から、ちょこちょこと使っているRaspberry Pi / volumioですが、あれこれといじっていると、たまにWEBUIが更新されなくなったりもします。 

Rasp11 

そんなときの対処方法など、分かってきたものだけ紹介いたします。

 

■NASやWindows共有フォルダを認識できない時

問題の多くは、Windows側の共有設定にあるような気もします。

http://windows.microsoft.com/ja-jp/windows/share-files-with-someone#1TC=windows-7
http://buffalo.jp/download/manual/html/bro180/manual/top/share3.html 
http://www.iodata.jp/support/product/hdl-gx/manual/htm/pc-share.htm 

こんな感じで、色々なサイトで詳しく説明があるのですが、それぞれ方法が異なります。Windows7では、色んな手順があって、それが初心者に混乱を招いているようです。
少なくとも、私は迷いました。 
win8や8.1ではどうなのでしょうか。

もし別のWindows機を所有しているのならば、そちらからアクセスして共有フォルダ内のデータにアクセスできるか調査するのが近道だと思います。

 

以下は、共有フォルダを開放できているという前提で進めます。まずは共有フォルダにパスワードを設定しない(誰でもアクセス可)で試しましょう。

NASやwindows共有のIPアドレス/共有フォルダがそれぞれ

 IPアドレス:192.168.1.xx

 共有フォルダ:music

とします。

Nas03

設定は、こんな感じです。  Username、Password は未記入でOKです。 

 

Nas01

うまく接続できていないときには、このように 赤い「×」が付きます。 NASの場合は、大文字・小文字にも注意しましょう。

 

WEB-UIからいくら接続を試みてもダメな場合、volumioにsshで接続して(sshのユーザ名/パスワードは root / volumio )、WEB-UIのソースコードを開きます。

nano というテキストエディタが使いやすいと思います。 UNIXユーザーはviでも良いでしょう。

 nano /var/www/sources.php 

 

Noatime 

 

85行目の マウントオプションの記載から「noatime」を削除します。 

「ctrl+o」で書き込んで「ctrl+x」で終了。  そして reboot します。 

NASによっては、これで無事に読めるようになるようです。 NASとの相性があるのでしょうか。  そもそもnoatimeオプションは無駄なアクセスを発生しないようにするものらしいのですが、NASによっては、このオプションが原因でマウントできないということのようです。

 

 

■コマンドによる強制マウント方法

上記を試してもダメな場合、強制的に手動マウントする方法もあります。 
なお、cifs-utils をインストールするとWEB-UIからはNASのマウントはできなくなるようですから最終手段と考えてください。

 

下記のコマンドで cifs-utilsをインストールします。 

  sudo apt-get update
  sudo apt-get install cifs-utils

インストールができたら、下記のマウントコマンドでNASをマウントします。   

  mount -t cifs //192.168.1.xx/music /mnt/NAS

 

ユーザーネームとパスワードを設定している時は、

  mount -t cifs -o username=XXXX //192.168.1.xx/music /mnt/NAS 

パスワードを聞かれますから入力します。
 Password: XXXX

確認は df コマンドです。

   /mnt/NAS

が見えていれば成功です。

WEB-UIから接続できなくても、mountコマンドで接続できればデータベースの更新は出来るようです。 

mountコマンドでNASを手動マウントした場合、次に起動するときには忘れてしまっているので、本来はWEB-UIからマウント成功をさせる必要があります。 NASの認識に関しての完成度は、もう一息なのかもしれません。 raspyFi でも同様なようです。 

  /var/www/_OS_SETTINGS/etc/fstab_raspberry

を編集して、起動時に自動でマウントさせてしまうという手もありますが、ここでは割愛させてください。 fstabの記載を間違うと起動しなくなることもあるので、注意が必要です。 

 

 

■WEB-UIに繋がらなくなった時

あれこれと、コマンド側からもWEB-UI側からもいじっていると、WEB-UIの応答が無くなったりします。

そういう時は、mpdを再起動させましょう。 

RaspberryPiの電源を入れなおしてもWEB-UIの応答が得られないときも試してみる価値はあります。

sudo /etc/init.d/mpd restart 

どうでしょう。

それでもダメなら、リブートしてみましょう。

reboot 

すべてが上手く行っている時にはコマンドを打つ必要はありませんが、ちょっとトラブったときにはlinuxらしさが垣間見えます。 どうにもならなくなった時にはSDカードへ元データを転送しなおす所から始める必要もあります。

 

 

■電源ONでmpdが正常に起動しなくなった時

poweroffコマンドやWEB-UIから電源OFFをしないで、強制的に電源を切っていたりすると、そのうちvolumioがmpdを正常に起動できなくなる症状が出ました。

この方法が正しいのか自信がないのですが、起動時にmpdを強制リロードするようにmpdの起動ファイルを書き換えました。  

  nano /etc/init.d/mpd

で編集します。 

Mpdstart

やや強引ですが、startオプションをrestartと同じように mpd_stopしてからmpd_startします。 編集は一行加えるだけですので簡単です。 

 

私の環境では、これで、いきなり電源OFFしていても、正常に起動できるようになりました。

色々、調べていて分かってきたのですがvolumio(RaspyFi ベース)は、SDカードにlogなどを普通に書き込みをしています。 SDカードは書換え回数に制限がありますので、品質の悪いカードの場合は近いうちに壊れることが予想されます。  まあ、カードは安いですから、バックアップしておいて、壊れたら使い捨てのようにするのが良いのかもしれません。

その点、ALIXを使ったVoyageMPDは、CFはリードオンリで使っていて、いかなるタイミングでの電源OFFでも、ファイルを壊さないようにしてあります。 さすがです・・・ というか、それが普通な気がします。

 

 

 

 

にほんブログ村 PC家電ブログ ピュアオーディオへブログ村ランキングに参加してみました 
他の方の記事も興味深いものがあります。


« Raspberry Pi / volumio のCPU負荷を計測 | トップページ | 対決は突然に VoyageMPD VS Volumio Pi »

Raspberry Pi」カテゴリの記事

コメント

たかじんさん
どうしてもwin7とのファイル共有ができません。
レジストリいじってもnanoで一文削除しても、
赤いバツが出ます。
たかじんさんはどうやって成功したのか、ヒントだけでもいただけないでしょうか?

hiro さん

最大の難関、WIN7の共有ですね。
別のPCがありましたら、そちらからアクセスできるか確認するのが良いです。
設定としては、

1.共有したいフォルダを右クリック->共有->ホームグループ(読み取り)

2.再び 共有したいフォルダを右クリック->プロパティ

3.共有タブ->共有ボタン ->  Everyoneが無ければ追加

4.共有タブ->詳細な共有 ->  アクセス許可ボタン -> Everyoneが無ければ追加

5.セキュリティタブ-> グループ名またはユーザ名に Everyoneが無ければ追加

6.プロパティ「OK」で閉じる

とりあえずパスワード保護なしで挑戦してみる。


共有フォルダへ「ユーザ」と「セキュリティ」両方ともEveryoneに開放するというのがミソです。 私も数時間悩みました。  ググってもなかなか出てこないですし。

すみません。 上記は、全てwin上での設定です。 

たかじんさん

回答ありがとうございます。
別のPCからWIN7の共有フォルダを確認することはできていますので、WIN7の方は問題ないと思います。
WIN7のipアドレスの固定もしています。

あと、考えられるのは、volumioのipアドレスの固定なのですが、ネットワーク画面でipアドレスをstaticにしても、画面を更新するとautoに戻っています。これは固定が失敗しているのでしょうか?

度々申し訳ありませんが、もう少しヒントをいただけないでしょうか?

hiro さん

恐らくIPアドレス固定になっていないですね。 
「SAVE CHANGE」 を押してもautoに戻ってしまうということなのでしょうか。

volumioを再起動してから、もう一度設定してみてはいかがでしょう。
staticのIPアドレスはDHCPの範囲外に設定したほうが混乱は少ないと思います。


DHCPでもアクセスはできるとは思うのですが、ネットワークの構成による部分もあるかもしれません。 例えばルーターで、有線LAN-WIFI間アクセスを許可しているとか、NAT越えが必要な接続になっているとか。。。

volumio側からpingをwin7へ飛ばして応答が帰ってくるのであれば、cifs-utilsをインストールしてmountコマンドを試してみるのも良いかもしれません。

たかじんさん

色々とアドバイスありがとうございました。
cifs-utilsをインストールしてmountを試してみたのですが、「mount:mount point /mut/nas does not exist」と出て、ならばマウントポイントを作成しようとmkdirを試したのですが、「mkdir:cannot create directory no space left on device」と出ました。

Linuxを勉強して、再度チャレンジしてみようと思います。

/mnt/NAS は最初からあるはずなので何かおかしいですね。

linux(UNIX)では、最初の数文字までキーボードで入力したところで、「tab」キーを押すと補間される機能がありますので、一致するファイルやディレクトリがあるとさくっと表示されます。 一致する名称が複数ある場合は、tabキーを2度連続で打つと一覧が表示されます。

つまり、tabを2度打ちしても候補が出てこないと、そのファイルやディレクトリが無いということが判ります。

あとは、大文字、小文字が別々に区別されるので注意が必要です。
つまり、/mnt/NAS と /mnt/nas は別のディレクトリです。 ヒントになれば良いのですが。。。

(winは大文字小文字が区別されたりされなかったり、表示名と実ファイル名が別々に保存されていたりと複雑なシステムです)

追記

SDカードをWIN7でNTFSフォーマットして、再度イメージを入れて試しました。
何もしてない、素の状態でWIN7とのフォルダ共有、ipアドレスの固定化に成功しました。

「SDカードのあまった領域をストレージとして利用」を行っているのですが、16GのSDカードで1.46Gしか容量が使えません。
原因はここにあるのかな?と勝手に思っています。

たかじんさん、色々とお手間を取らせてしまい、すみませんでした。
そして、ありがとうございました。

これを見ている方で、同じ問題になっている方、先にNAS設定をすればうまくいくと思います。

hiroさん

無事に動いてよかったです。 SDに書込みできない状態になっていたのかもしれません。 起動時にシステムディスクにエラーが起こるとリードオンリマウントをするようになっていますから、その状態で起動していた可能性もあります。

本当は、win側で、余った領域をパーティション切って、フォーマットして、そこにmp3などのデータを転送できれば良かったのですが、なぜか出来なかったのです。
Linux上からは、特に問題なくパーティション設定やフォーマットなどできるのですがね。
もしかしたらパーティション設定専用のソフトを使うとできるのかもしれませんが、試していません。

不思議なのは、Linux側でFAT32でフォーマットしたパーティションは、SDカードをPCに挿しても認識できない点です。

たかじんさん

わたしもwin7PCの共有ファイルに音楽データを入れて再生を楽しみたいとラズベリーパイとSaberBerry+を購入いたしましたがNASを認識させるのに苦労しました。

わたしの場合は当初ドライブ全体を共有にしていたのですが、これがダメでした。

結局、ドライブの共有をやめ、その下に新たに共有用のファイルを作成し、パスワードを設定しました。

ここで、volumioのnasの設定で、user名とpasswordをあからさまに設定することで、やっとPC内の音楽ファイルをラズベリーパイで認識できました。

本来ならばアドレスの固定などをしなければならないのかもしれませんが、取り敢えず現在のところ滞りなく再生できています。

やっとここまで来ましたので、今後は本格的に音出しをしていきたいと思っています。

書かれているマニュアル内容と異なる部分がありますのでちょっと心配ですが、こんな事例もあるのだということお知らせしたくメールをさしあげました。

ありがとうございました。


とうまささん

こんにちは。 この記事の内容は、volumio 1.1Betaの頃の話で、現在のバージョンとは状況が異なっているかもしれませんね。

Win7の共有設定は、本当に難しいです。 方法がひとつではないという部分も混乱を招く原因のひとつと思います。 win98のときは簡単だったのですが。。。 
 
無事に繋がったようで何よりです。 

たかじんさん

Rapsberrry Pi2 とSaberBerry+ を使う準備をしておりますが、音声出力に数十秒おきくらいのランダムな頻度でジージー、チリチリなどの雑音が出ます。雑音の継続時間は数秒程度です。どうしてもこの雑音を無くすことが出来ません。解決のヒントがありましたら、教えていただきたいと思います。

なお、下記の設定で使用しています。

OS:Volumio Ver.1.55 又は RuneAudio_rpi2_0.3-beta
電源:5Vスイッチング電源 又は、12Vスイッチング電源+3端子レギュレータ 5V出力
LAN:有線 又は、WiFi子機からLAN端子に接続
音源:(1)NAS接続したPCのHDDまたはBUffaloのNASに記録したWAVおよびLAAC
(2)Rapsberry Pi2のUSB端子に接続したHDDおよびUSB メモリー

上記の設定で、いずれでも雑音が生じます。なお、Rapsberry Pi2のUSB端子に接続したUSB-DACの音声出力には雑音は入りません。
以上、よろしくお願い致します。

あすかさん

横から失礼します。

>なお、Rapsberry Pi2のUSB端子に接続したUSB-DACの音声出力には雑音は入りません。

ということは、現象面からみるとRPiとDAC基板が原因ではなさそうですね。

どの電源でも問題ありませんか?
RPi2はPRiよりも消費電力が大きいと思いますが、容量は大丈夫です?

mr_osaminさん

コメントありがとうございます。

電源容量は、5Vスイッチング電源の場合はMAX 2.4A、12Vスイッチング電源+3端子レギュレータの場合はMAX 3Aのものを使っております。両方ともに雑音が出ます。電源容量については配慮しているつもりで、MicroUSBU電源ケーブルもタブレットなどの充電に用いる2A用の太いものを使っています。

現象的には、RPi +外付けUSB-DACでは雑音が出ないので、I2Sに関係する部分に原因があるのかなと思います。

以上です。

あすかさん

とても判りやすい状況説明ありがとうございます。
ノイズ源の特定と対策が必要かと思います。

wifiドングル、USB-HDDなど、原因切り分けのためには一旦、外して検証すると判別しやすいと思います。 


ノイズ源として可能性が高いのは、
1.DC電源(特にスイッチング電源)
2.外来ノイズ(電波、ACコンセント)
 -> RCAケーブル、LANケーブル、電源ケーブルがアンテナとなってRaspberryPiに取り込んでしまう。

ノイズ音の聞え方からすると、外来ノイズの可能性が高いような気がします。


RaspberryPiの近くにWIFIルーターなどがある場合、一度WIFIをOFFにしてみるなど、ノイズ源の特定をしてみるのも良いと思います。 家の近くに電波塔(放送局、中継局、携帯基地局、船舶ビーコン等)があると、案外、ノイズが入りやすかったりします。 

私の家でも、40mくらいの距離にUQ-Wimaxのアンテナ塔が設置され、300-400mくらい離れた丘の上には何かの中継局がありまして、RCA端子からノーシールドで1mほど配線するとノイズが聞えることがあります。 (Raspberryでなはく、iPodやCDとヘッドホンアンプ間のRCAを伸ばしても聞える)

電波対策としては、基板からRCA端子までのノーシールド部を極力短くすること。 金属ケースにいれてシールドする、RCAケーブルはシールド線を使うことです。 
それでもノイズが聞えるきは、LANケーブルを外してもノイズが聞えるかどうか。
また再生したときに発するのか、再生していなくても出るのか。 
アンプを接続せず、直接DACの出力をヘッドホンに接続するとどうか。 それでもノイズが聞えるのであれば、電源側の可能性が高くなってきます。


電源のほうは、容量不足以外にも、もともとノイズを沢山発するスイッチング電源があります。(大電流出力スイッチング電源のほうが発するノイズが大きい傾向にあります) また、三端子レギュレータを介した場合でも、スイッチングノイズは多少減衰しても、完全に消えることはありません。 

mr_osaminさん

コメントありがとうございます。 おっしゃる通り原因のひとつとして電源の可能性はあると思います。 

たかじんさん

ご返事ありがとうございます。
ノイズの現れ方ですが、音楽が鳴っていない時は、全く無音でノイズはありません。音楽が鳴っているときに出ます。PCM信号で言えば、LSB側の何ビットかに障害がでているような感じで、小音量時に目立ちます。DA基板の音声出力部分からRCA端子までは、10cmのシールド線で結線しています。このあたりで、ノイズを拾う可能性は殆どないと思います。また、拾っている場合には、音声の有無に関係なくノイズが出ると思います。

ノイズ源の特定のため、LANケーブルを接続した状態で、パソコンのWEB-UIから音楽をプレーし、その後LANケーブルを抜き、RPiには、音楽を入れたUSBメモリーと電源ケーブルだけにしました。その状態でもやはりランダムな頻度でノイズが出ます。

この時に、直接外部とつながっているのは、電源ケーブルと音声出力ケーブルだけですが、電源からのノイズの混入の可能性がありますので、リニア電源を用意して試してみようと思います。

なお、念のため別の部屋で動作させた時にも、全く同様のノイズが混入しました。

現状は、以上の通りです。よろしくお願い致します。

あすかさん

RaspberryPiとDAC間のI2S信号の経路は、5-7cm程度と短く、信号も3.3Vの振幅があるため、ビットが間違えるほどのノイズの混入というのは可能性としては低いと思います。
またLSB側だけに乗るという傾向も、ランダムなノイズとしては、なかなかできる芸当ではありません。

そして、音楽を再生していないときには一切聞えないという観点からは、電源から回り込むノイズの可能性も微妙ですね。 
音声が入っていないWAVファイルとか、-90dBくらいの正弦波のファイルを作って、それを再生してみるというのはいかがでしょうか。

何かしらの原因により、DAC-IC内部、もしくはRaspberryPi のシリアル送信部の特定bitが故障してノイズが発生しているなんてこともあるのでしょうか。  そんな現象だと、三角波を作ってオシロでみてみるくらいしか検証する方法を思いつきません。

たかじんさん

-90dBのWAVファイルでテストをしましたが、ノイズはありません。また、1KHzと200Hzの3角波で-40dBのWAVをWG150信号発生ソフトで作り、USBオシロ(DDS140)で50mV/devのレンジで見た限りでは、ビット落ちの様子は見受けられませんでした。オシロと言っても簡易なもので、測定器自体のノイズが10mV程度乗っており、細かな波形の観測はできません。もっと小さな値のbitで何かが起こっているかもしれません。

現象的には、どうも定常的な信号では、ノイズになるような破たんは生じていないようです。しかし音楽信号のような変動する信号の場合にノイズが出るようです。

以上、調べた結果です。よろしくお願い致します。

あすかさん、たかじんさん

USB経由でもノイズが乗るとおっしゃっていたので、LAN経由からのノイズではないのかなと思い、あとは電源かなと推測しました。

LAN接続のまま、USB再生の組み合わせだとLANからの可能性もあるかもしれないですね。


最近、HUBをカスケードするとデジタルフィルターの役目になるという噂を聞きつけて実験中です。

あすかさん

オシロをお持ちということで、かなり正確な情報把握ができていますね。 助かります。 

ですが、なかなか不思議な現象が起こっているようですね。 正弦波、三角波だと発生しないけど、音楽だとノイズが聞える。。。

DACの動作やI2Sの通信として、低い周波数だけノイズがでるとか、高い音を再生したときだけノイズがでるということは、あまりないような気がします。(ヘッドホンやスピーカのビビリは周波数依存することがあります)

また、DACが消費する電力は、音楽信号でも正弦波、三角波でも殆ど変わらないと思います。 ですので電源の負荷によるノイズ発生の可能性も低そうです。 

USBメモリから再生しているとのことで、そちらのアクセス時の電流変化のほうが大きいと思います。 MPDがデコード動作するときと、データをデバイスに流しているだけの時とが交互にCPUへの負荷が変わるので、そこでも電流変動がありますね。 
ただ、それも正弦波と音楽を再生したときに、そんなに差がでるとは思えないです。

あとは、どの曲でもでるのか、特定のアルバム、特定の曲ででるのか。  実は録音された曲の中にノイズが混じっているということはないですよね。。。

一度、SDカードに曲を入れて再生してみてはいかがでしょうか。 USBとLANを介さずに再生ができますので、そちらの影響も取り除いて検証が可能です。

mr_osamin さん

アイデアありがとうございます。
LAN経由でノイズが発生するケースもあるようです。 HUBの種類による違い、外来ノイズなどの原因が考えられますね。 あすかさんは、LANを切り離しても実験していただけてますので、とりあえずLANだけが原因ということではなさそうな気配です。

たかじんさん

ありがとうございます。

今使っている音源は、CDからiTunesを使ってALACで取り込んだものが殆どです。今回、ノイズを調べるために、新たにWindows Media PlayerでWAVで取り込んだものも使っています。これらの音楽ファイルは、iTunesやfooberで使っていますが、今までノイズが問題になったことはありません。なお、前にも書きましたが、RPiのUSB端子にUSB-DACをつないで、その音声を聞いた場合にはノイズはでません。

今回のノイズですが、特定のアルバムや特定の曲で発生すというより、どのアルバムや曲でも発生します。若干、ノイズが出やすい曲もありますが、ある程度の時間聞いているとやはりノイズが出ます。一般的には、曲の始まりではよく出ますが、途中でも出ます。

SDカード(Ramplay)に曲を入れてテストしてみましたが、やはりノイズがでます。もちろん、USBメモリーやLANケーブルを外した状態です。

mr_osaminさん

コメントありがとうございます。
たかじんさんもお書きになっていますが、テストではLANケーブを抜いて、その影響が出ないようにしていますが、やはりノイズが出ます。

以上、現状です。よろしくお願い致します。

たかじんさん

トランス式の電源に変えてみましたが、変化はなく、やはりノイズが出ます。

以上、追加の情報です。よろしくお願い致します。

あすかさん

一度整理しましょう。

・再生していないときはノイズは聞えない。
・音楽(ALAC)ではノイズが聞える。
・正弦波、三角波(WAV)ではノイズはでなない。
・LAN、USBは全て抜いても状況変わらない。
・USB-DACでは音楽(ALAC)でもノイズは聞えない。
・データは44.1kHz/16bit
・電源は今のところスイッチングアダプタを使用

ということですかね。
ファイル形式と、I2Sのシリアル出力ドライバに起因するような気がしないでもないです。 一度、正弦波、三角波をALACに変換して試してみるというのはいかがでしょうか。

あとは擬似的に音楽信号のように、音がおおきくなったり小さくなったりを再現するため、トーンバースト信号を作って、それをオシロで観測してみるというのもアリかもしれません。
トーンバースト信号は、1kHzで8波ON、24波OFFが標準です。 観測しやすいようにアレンジしてもよいと思います。

たかじんさん

お世話になっております。ありがとうございます。

整理していただいた項目の内、

第2項については、WAVの音楽でもノイズが出ます。Windows Media Playerで今回新たにCDから取り込んだWAVファイルでも出ます。

第6項については、手元の44.1KHzのALACおよびWAVのファイルをAV Audio Converterを使って192KHz/24bitにアップコンバートしてテストしましたが、結果はやはりノイズが出ます。

第7項については、現在リニア電源に切り替えてテストしていますが、ノイズは相変わらず出ています。スイッチング電源の場合と違いはありません。

正弦波、3角波のALACを試してみましたが、異常は見られません。また、1KHzのトーンバーストの再生波形も手持ちのUSBオシロでは異常は見られません。オシロの性能が悪く、このような観測には無理があります。

以上が、現状です。お手数をおかけして申し訳ありません。よろしくお願い致します。


あすかさん

なるほど。

・WG150で作成した正弦波、三角波だとWAVでもALACでもノイズは出ない。
・CDから取り込んだ音楽だとWAVでもALACでもノイズが聞える。
・電源はスイッチングアダプタでもトランス電源でも変わらない。
・44.1k/16bitでもアップコンバートした 192k/24bitでも同様。

ということですね。  なかなかしっぽがつかめないですね。。。。

CDからの取り込みでノイズが混じっている可能性というのはないでしょうか?
USB-DACの性能が不明確ですがハイレゾ対応DACではなくて(帯域が狭くて)、感じにくかったノイズが明確に聞えてきた。 なんてことは、あまり考えたくはないですが。。

http://www.2l.no/hires/

念のため、こちらの音源を使ってテストしてみてはいかがでしょうか。

ちなみに、DAC出力にヘッドホンをダイレクトに接続して聞いてみましたでしょうか?
最初の書込みのノイズ音の混じり方は、何かしら(電波系)の飛び込みノイズ音にみえてしかたありません。 音量はソフトウェアボリュームにて減衰させてください。

たかじんさん

DAC基板から直接ヘッドホンにつなぐと音量がとても小さく判定ができませんでした。
USB-DACは、DA-300USBです。
WWW.2L.noからダウンロードしたファイルの再生ですが、最初の3曲だけ試しました。1曲目(192KHz/24bit)は頻繁にノイズが出ました。2曲目(192KHz/24bit)は、他の曲よりも低いレベルのノイズが、9分15秒の間に1回10秒程度出るのに気が付きました。3曲目(96KHz/24bit)は、頻繁にノイズが出ました。

以上です。

あすか さん

> DAC基板から直接ヘッドホンにつなぐと音量がとても小さく判定ができませんでした。

なるほど。 あすかさんのことですから、いくつかのヘッドホンで試されたとは思うのですが、2VrmsでるはずのDAC出力でヘッドホンからの音が小さすぎるということは、DAC-ICがおかしい可能性が高いですね。(600Ω300Ω等で超低感度なHPを使わない限り、音が大きすぎる状態になります) 

メールを差し上げますので、一度基板をお送り下さいますようお願いします。

お手数おかけしますがよろしくお願いいたします。

たかじんさん

お世話になっております。

DA基板から直接ヘッドホンにつなぎ確認する件ですが、RCA端子からヘッドホンプラグに接続する際に用いたケーブルが不適当なものでした。改めて別のケーブルでDACから直接ヘッドホンにつないだ結果、音量は正常(ソフトボリュウムで調整)でした。しかし、ノイズの状況は変わりませんでした。

私のところではこれ以上はわかりませんので、基板を返送致しますので、お調べいただきたいと思います。

お手数をお掛けしますが、よろしくお願い致します。

横から失礼いたします。

あすかさんとたかじんさんのやりとりで気になっています。

正弦波はOKで、音楽でNGとなるノイズの原因とは
一体どんなものなのでしょうか?

たかじんさん

本日の12時10分のコメントは、表示では、投稿者が「たかじんさん」となっていますが、「あすか」が投稿したものです。名前欄の記入を間違えました。失礼いたしました。

picoさん

コメントありがとうございます。たかじんさんといろいろやり取りしておりますが、私の方では、残念ながら原因はわかりません。

以上です。よろしくお願い致します。

あすかさん

配線ちがいで、ちゃんとした音量で聞けたんですね・・・
それだとDACの出力不足とも言えないですね。 なぞです。

picoさん

どちらかというと、単純な音に別の音が混じると判別しやすいので、正弦波の方がノイズ判別はしやすいです。 オシロのXYモードで観測しながら聞くと、更に発見しやすくなります。

音楽だと複雑な波形ですし、音が沢山入っているので聞きなれた人にしか判別できないとか、録音自体に含まれている音だったりと、定量的な判断はしにくいのです。

でも、CDの音トビ判定はテストディスクで行なうのですが、これには音楽が普通に入っています(笑 

picoさん

 たかじんさんに問題の基板を調べていただいた結果、片方のチャンネルのみ、特定の音量でノイズが聞えやすく、正弦波でも歪んでいることがわかったとのことでした。

 私が正弦波(-40dB)でチェックした時にも波形に歪があったと思いますが、正弦波に連続してひずみ成分が重畳していましたので、音楽信号の場合に発生したようなノイズとは全く異なっており、ヘッドホンで聞いてもノイズとしては検知できませんでした。

 このために、正弦波ではノイズがでないと表現してしまいました。音楽信号の時に聞こえていたノイズは、音の強弱に伴って生じており、不連続に発生するため、容易に検知できました。

 以上です。

あすかさん

ですね。 少し不思議な壊れかたをしていたように思います。

正弦波だと、音量が一定の音なので、高域に「チー」という音が特定の音量だと一緒に重なって聞えました。  これが複雑な波形の音楽だと、何か外来ノイズのように、特定の楽曲の特定の再生位置で「ジリジリ」という音に聞えるっぽです。 
ある程度、大きな音量で音楽が鳴り続けると、それはそれでノイズを認識できなくなるようで、曲によっては殆ど感知できないという難易度の高いものだったように思います。

あすかさん
たかじんさん こんばんは

とても参考になりました。ありがとうございました。 正弦波でもノイズは発生していたけど音楽の中で聞くノイズとは違うように感じたということですね。 
sabreBerryを購入する決心がつきました。
どんな音がするのか楽しみです。
少し古いけどNP-S2000を父が所有しているので聞き比べたいです。

picoさん

よろしくお願いいたします。
NP-S2000はYAMAHAのネットワークプレーヤーですか?
薄くて、デザインいいですよね。 DAC回路のアナログ部もとても凝っている素晴らしいプレーヤーと思います。 さすがにそこまでSabreBerry+の能力は及ばないんじゃないかと思います。

たかじんさん こんにちは

sabreBerry+とNP-S2000を聴き比べてみました
この小さなDAC基板から出てくるとは思えない音質で驚きました。

NP-S2000は全体的にゆったりしているけどキレが少ないです。 sabreBerry+は、カッチリして低音の解像度が素晴らしいです。 好みの問題だと思うけど、こんなに物量が違うのに拮抗する音質がでることに驚きを隠せません。

電源はトランスでDC5Vを作りました。 次はRUNEAUDIOに挑戦してみます。

こんな素晴らしい基板をありがとうございます。

picoさん こんばんは。

聴き比べてしまいまいたか。
http://techon.nikkeibp.co.jp/article/LECTURE/20120509/217092/?ST=lsi&P=1
このページを見ても、DA変換基板のサイズから、かなりの力の入れようだということが伝わってきます。

sabreBerry+の小ささで、比べられるとちょっと恥ずかしい気分になりますね。
picoさんの電源などの組み合わせの上手さもあるのだと思います。
やっぱりトランスで作る電源は、ノイズ成分に高い周波数が含まれていなくて、オーディオには適しているのだと思います。
市販のオーディオ製品も、高級機になれば必ずといっていいほど巨大なトランスが採用されますから、スイッチング電源のメリット(電圧の安定度や発熱の少なさ)より、トランスの音の良さをとっているんだと思っています。

こんにちは
VolumioのNASの設定でわかったことがありますので報告します。
自宅ではBuffalowのワイヤレスルータをつかっていますが、ここにUSB
端子がついていて、音楽の入ったメモリメモリstickをさして、NASに
したかったのです。
ルータのNAS設定画面からUSBのNASを設定し、PCからアクセス
できるようになました。 つぎにラズパイのVolumioのネットワークのIP
arressをしらべてwebからIPアドレスを入力し、VolumioのWEB 
GUI画面からのスタートです。
MENU→ Library→NAS mountsで一通りの設定がおわっても
×がついてしまってる場合がありました。
何回見直しても設定できないのであきらめていましたが、
あるサイトでBufflowのNAS設定では +show advanced options
をさらにあけてMount flagsの設定にro,dir_mode=0777,file_mode=0777,sec=ntlm
さいごに,sec=ntlmの記述がないと認識しないとかいてあったので
いれて SAVE MOUNTすると認識できました。
お試しください。


hirokenさん

buffaloのNASは「sec=ntlm」を入れるというのは、別の所でも話題になっていました。
が、ルーターのUSBポートを使った例はなかったと思います。

情報、ありがとうございます。

USB-HDDを繋げると、NAS要らずですね。 便利かも。 

そういえば、エプソンのプリンタにもUSB端子が付いていてストレージに使えるので、NAS代わりになるのだろうか。。。

コメントを書く

(ウェブ上には掲載しません)

トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/587107/58995819

この記事へのトラックバック一覧です: volumioのトラブルシューティング?:

« Raspberry Pi / volumio のCPU負荷を計測 | トップページ | 対決は突然に VoyageMPD VS Volumio Pi »

サイト内検索

Sponsors link

2017年6月
        1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30  

最近のトラックバック

無料ブログはココログ